EllisLab text mark

This is an archived forum and may no longer be relevant. The active forums are here.

Advanced Search
Permissions problem uploading files
Posted: 28 April 2012 01:21 AM
Joined: 2007-06-09
16 posts

Hi guys,

I’ve got a weird issue happening. I can upload talks logged in as Super Admin, but uploads silently fail when I’m using a non-SA user.

Config: EE 2.4.0 build 20120123, running on LAMP
Group: Talk Uploaders
Key Group permissions: Access CP, Access Content/Edit/Publish, Access File Manager
File Upload Location permissions: Enabled for Talk Uploaders group

Steps to repro
1. Login as Talks user.
2. Publish > New Entry
3. Click ‘Add Files’ in the custom File field.
4. File Manager dialogue appears as per normal - click Upload File.
5. Browse to file (mp3) and click Upload File to trigger upload.
6. Browser will submit the file.
7. Once it hits 100%, the spinning icon will continue to sit there.
8. Check file upload directory - no file.

Logging back out and coming in as an SA - upload succeeds.

It seems to be permissions related, but (a) I can’t figure out what permission, and (b) I’m not getting any sort of error message at all.

Any ideas?


Posted: 30 April 2012 12:46 PM   [ # 1 ]
Joined: 2005-10-18
7338 posts

Hi Sam,

I’m sorry you are having trouble with certain groups uploading files!

Thanks for listing out all the permissions you have assigned to the group. One key permission that is not listed, I assume is set correctly, but will you verify? Has the group been granted access to the post to the channel itself?

Have you tried uploading any other file type as a test?

Have you verified permissions on the folder itself to be 777? It shouldn’t be a factor, but it’s worth a look to be sure.


Posted: 30 April 2012 07:01 PM   [ # 2 ]
Joined: 2007-06-09
16 posts

Hi Dan,

Yes, tried other files, yes, channel posting privs, and yes, 777.

After a lot of trial and error I found the problem.

Member Groups need to have “Can administrate file upload preferences” under Content Administration set to Yes to allow file uploading. If I turn it off again - uploads fail.

Which is obviously confusing because I don’t want to give administration access, just uploading via the Publish screen perm’s.

Obviously very confusing, and also annoying that there was no clear error message.

It would be really helpful if this could be a Wiki/documentation article somewhere - it was a very frustrating and un-intuitive experience to get going (and I work in web dev for a job!).


Posted: 01 May 2012 03:09 PM   [ # 3 ]
Joined: 2005-10-18
7338 posts

Hi Sam,

You will get no arguments from me!

I’ll get this in as a documentation story so we can get that clarified. Thank you for bringing this to our attention and for your persistence!

Is there anything else I can assist you with?