EllisLab text mark
Advanced Search
     
The URI you submitted has disallowed characters.
Posted: 28 August 2007 05:47 PM
Joined: 2006-07-16
11 posts

hello… I trying to post these uri

thelist2[]=some.avi
but… i get the The URI you submitted has disallowed characters….
even I replace the [] characters to nothing… to send thelist2=some.avi and I get the same error…

any ideas?

thks

 Signature 

Chile | Debian 2.6.17 | CodeIgniter 1.5.1

 
Posted: 28 August 2007 06:07 PM   [ # 1 ]   [ Rating: 0 ]
Avatar
Joined: 2006-06-23
370 posts

You need to add “=” to your allowed_uri_chars. You’ll find that string in your config/config.php file.

 Signature 

Mac OS X 10.8, Apache 2.x, NGiNX, PHP 5.4.x, CodeIgniter 1.7.2/2.1.3

 
Posted: 28 August 2007 06:14 PM   [ # 2 ]   [ Rating: 0 ]
Joined: 2006-07-16
11 posts

Hi.. thks for the answer… I add the ‘=’ in the config.php… but I get this

SeverityWarning

Message
preg_match() [function.preg-match]Compilation failedrange out of order in character class at offset 18

Filename
libraries/Router.php

Line Number
408 

thks.

 Signature 

Chile | Debian 2.6.17 | CodeIgniter 1.5.1

 
Posted: 28 August 2007 06:33 PM   [ # 3 ]   [ Rating: 0 ]
Avatar
Joined: 2006-06-23
370 posts

It could also be the . (dot) in there. Try adding a dot instead. You need to be a little bit brave and experiment to figure out what works.

Also, do you have a “?” in your link? Please provide the full link.

Lastly, play with the “uri_protocol” setting. If you have a “?” in your link, you may need to change your protocol to REQUEST_URI.

 Signature 

Mac OS X 10.8, Apache 2.x, NGiNX, PHP 5.4.x, CodeIgniter 1.7.2/2.1.3

 
Posted: 28 August 2007 06:36 PM   [ # 4 ]   [ Rating: 0 ]
Joined: 2006-07-16
11 posts

na..is not the dot… because is allowed in the config.php…
and when u send query string.. a=1&b=2&c=3 there is no problem…

 Signature 

Chile | Debian 2.6.17 | CodeIgniter 1.5.1

 
Posted: 28 August 2007 06:40 PM   [ # 5 ]   [ Rating: 0 ]
Joined: 2006-07-16
11 posts

ah… and the ‘?’ I’m using prototype… making an ajax.request to the ‘?’ is handled by prototype…

 Signature 

Chile | Debian 2.6.17 | CodeIgniter 1.5.1

 
Posted: 29 August 2007 01:17 AM   [ # 6 ]   [ Rating: 0 ]
Avatar
Joined: 2007-07-14
171 posts

I had a similar problem and I disabled fastcgi on my server and everything went back to normal.

 Signature 

Hell Horror - CodeIgniter Community for Horror Movie Fans

 
Posted: 27 February 2008 10:27 AM   [ # 7 ]   [ Rating: 0 ]
Joined: 2007-11-05
27 posts
latuss - 28 August 2007 10:40 PM

ah… and the ‘?’ I’m using prototype… making an ajax.request to the ‘?’ is handled by prototype…

I am using it through JScript and am unable to add
&’ or ‘ = ’ to the $config[‘permitted_uri_chars’] as it gives the below error ...

A PHP Error was encountered
Severity
Warning

Message
preg_match() [function.preg-match]Compilation failedrange out of order in character class at offset 18

Filename
libraries/Router.php 

please suggest how to activate it..?

as i am using JQuery ThickBox and it adds ‘?’ and ‘=’ and ‘&’ to the url..

 
Posted: 27 February 2008 10:44 AM   [ # 8 ]   [ Rating: 0 ]
Avatar
Joined: 2008-01-07
2507 posts

Do not add it to the end of the allowed chars, since the last character is a dash so it will interpret it as _ to = .  You can either escape it by adding a backslash or place the = sign in the second to last spot.  Remember that it’s really just a regular expression.

 Signature 
 
Posted: 27 February 2008 11:09 AM   [ # 9 ]   [ Rating: 0 ]
Joined: 2007-11-05
27 posts

I figured that out but now i am in a new problem,

few thinks works fine in FireFox but in IE it still gives error..

This is working(in FF only)
http://localhost/myci/auth/register/reg4feed/question/41&random=1204176581406

but the below these don’t work http://localhost/myci/auth/login?width=300&height=200&random=1204176570750

can anyone guess whats wrong..
I am using Matchbox Module Modular separation, is it causing the problem..?

I found that you have to pass a parameter for the function in my case “auth” is the module and “register” & “login” are controllers.

please help

 
Posted: 16 March 2008 05:22 AM   [ # 10 ]   [ Rating: 0 ]
Joined: 2008-03-16
4 posts

Hey,

I do have the same problem. dont know how to solve it.. i have added ‘=’ to my <<$config[‘permitted_uri_chars’] = ‘a-z 0-9~%.:=_-’; >> but it is not working.

i am using a javascript function which is calling a function from a controller…the function is like this

function load_form(){
    xmlHttp
=GetXmlHttpObject();
     if (
xmlHttp==null)
     
{
         alert (
"Browser does not support HTTP Request");
         return;
     
}
    
var url="<?=base_url()?>index.php/a_form/load_form";
    
xmlHttp.onreadystatechange=load_a_form
    xmlHttp
.open("GET",url,true);
    
xmlHttp.send(null)

but showing the message “The URI you submitted has disallowed characters”
can anyone help me?

 
Posted: 16 December 2008 11:30 PM   [ # 11 ]   [ Rating: 0 ]
Joined: 2008-12-16
2 posts

I had the same problem using JQuery, here is the solution:
$config[‘permitted_uri_chars’] = ‘a-z 0-9~%.:?=_\-’;

Good Luck

Garry

 
Posted: 19 June 2010 10:43 AM   [ # 12 ]   [ Rating: 0 ]
Avatar
Joined: 2008-01-18
8 posts

Hi,

I am having the same problem on my machine running Ubuntu 10.04

When i try to access a url http://localhost/dpscampus/user/login, it gives me an error

The URI you submitted has disallowed characters.

Although the url contains only characters, but still it shows the same error.

It was working fine on my system running 8.10 version of Ubuntu.

Kindly help.

 
Posted: 10 May 2011 03:24 PM   [ # 13 ]   [ Rating: 0 ]
Joined: 2011-05-10
1 posts

I had the same issue after migrating an old site to a new server running ubuntu 10.04. I discovered the source of the problem is in “system/libraries/URI.php”:189. Due to a change in preg_quote as of php 5.3.0:

5.3.0   The - character is now quoted

This will cause the - in “a-z” and “0-9” to be escaped and thus changing completely the resulting expression.

I’m not using CI anymore and just wanted the old site (which is an internal demo) to run so I did not try to find an elegant fix and just removed the preg_quote call and quoted them myself in $config[‘permitted_uri_chars’].