EllisLab text mark
Advanced Search
     
reCAPTCHA in EE2, multiple captcha input fields
Posted: 21 December 2012 12:35 PM
Joined: 2012-07-23
2 posts

I’m using reCAPTCHA on my EE2 site’s member registration page, but the native captcha input field is still showing up below the reCAPTCHA box (see attached screenshot).  The form is functioning properly as long as the captcha is input into the reCAPTCHA field, but it’s confusing for users since there are two boxes.  I can’t figure out how to turn off the native captcha field without turning off reCAPTCHA.  Any suggestions?  Is it possible to edit the member registration template and simply remove the input field?

Thanks

Image Attachments
recaptcha.png
 
Posted: 21 December 2012 03:05 PM   [ # 1 ]   [ Rating: 0 ]
Joined: 2012-07-23
2 posts

I’ll answer my own question, for anyone else having the same problem.

The captcha input field needs to be set to “display: none” in the registration page template.  In the control panel, go to Design > Themes > Member Profile Templates, and select your site’s theme, or default if no theme is set.  Click on “Registration Form” and edit this code, located near the bottom, below the {captcha} tag: 

<input type=“text” name=“captcha” value=”” size=“20” maxlength=“20”  />. 

Add “display: none;” without the quotes to the style section.  It should look like the attached screenshot.  Deleting the input will break the captcha system, so setting it to display: none is the way to do it.  If you are also using the discussion forum module, you’ll need to do the same thing in the Design > Themes > Forum section if members register via the forum registration page.

Image Attachments
captcha_fixed.png
 
Posted: 22 April 2013 05:01 PM   [ # 2 ]   [ Rating: 0 ]
Joined: 2008-03-25
179 posts

Thanks for this Roger.  I’m still getting an error and didn’t know if you may know why - every time I submit I get the following:

Please type both words that appear in the image

I’ve tried a dozen or so times, so I know its not just typos…

Any thoughts?