EllisLab text mark
Advanced Search
     
URL not allowed charcter in CI 2.1.*
Posted: 25 October 2012 10:01 AM
Avatar
Joined: 2011-10-29
11 posts

Hello Team,

I just want to pass data through URl.

However the data is more secure so i just want to use the base64_encode while data passing.But it through me the error. So is there any one to help to sort out this issue.

Thanks.
Sanjay

 Signature 

Sanju..South D Fire….
.(JavaScript must be enabled to view this email address)

 
Posted: 25 October 2012 10:11 AM   [ # 1 ]   [ Rating: 0 ]
Avatar
Joined: 2011-10-12
112 posts

config.php Line 129

$config['permitted_uri_chars'
 
Posted: 25 October 2012 10:29 AM   [ # 2 ]   [ Rating: 0 ]
Avatar
Joined: 2011-10-29
11 posts

Hi,

I Will do it. However it can create any issue with security.

 Signature 

Sanju..South D Fire….
.(JavaScript must be enabled to view this email address)

 
Posted: 25 October 2012 12:14 PM   [ # 3 ]   [ Rating: 0 ]
Avatar
Joined: 2009-02-19
4534 posts

It would be MUCH better to pass things that are meant to be private via session or something.  Not the URL.  Then you don’t have to open yourself up to vulnerabilities by allowing those characters that are causing the disallowed characters error and you can leave those settings alone.

 Signature