EllisLab text mark
Advanced Search
     
New Channel not showing up in Publish or Edit Tabs
Posted: 27 January 2011 04:40 PM
Joined: 2011-01-27
2 posts

I’ve created a new Channel and a new template group for an additional blog on my site by essentially duplicating the existing blog and modifying the templates. I can publish a single page via the “Structure” module but I don’t see the Channel in the Publish or Edit menus/pages. If I try to Add/Edit entries for a new page using this channel, I get an error saying “You are not authorized to post to this channel.”
If I go to Pages > Edit Channels, the new channel is there, but it doesn’t show up in the drop down. Without being able to add entries to the blog page, I can’t populate the page or any entries. I’ve searched through the EE and BuildwithStructure forums and can’t find anything. Am I missing something obvious?

I’m running ExpressionEngine Core 1.6.8 with the Structure Module version 2.0.9

 
Posted: 21 February 2011 11:32 AM   [ # 1 ]   [ Rating: 0 ]
Joined: 2011-01-27
2 posts

This problem continues to persist. I’m noticing that any new “channels”, as they are still called in this version of EE, do not appear in the Publish or Edit menus. I am picking up where another developer left off and it seems that he may have been in the middle of an upgrade(?). In the template files, everything is referred to as a “Weblog” but in the Control Panel everything is referred to as a Channel.

Do you think that this might have something to do with why I cannot create new channels and if so, how can I resolve the issue?

 
Posted: 22 February 2011 12:12 PM   [ # 2 ]   [ Rating: 0 ]
Avatar
Joined: 2006-09-06
513 posts

In EE1 the term is “weblog”, but you can change the word that is used CP Home›Admin›System Preferences›General Configuration›2nd field from bottom. I assume the pervious developer changed that to “Channel”. In the templates you still use “weblog”.

Regardless, are you sure you are using an Super Admin account? If not, the Member Group you belong to might not be assigned to that “Channel”.

Try checking CP Home›Admin›Members and Groups›Member Groups›Edit Member Group› “whatever Group you are assigned to” and then “Channel Assignment” and make sure those new “Channels” are set to “yes”.

 Signature 

Kyle Summer | smartpill design | New Haven, CT |  twitter