EllisLab text mark
Advanced Search
     
Flexigrid not display
Posted: 07 April 2009 04:38 PM
Joined: 2009-04-07
1 posts

Hi,
I do not know why flexigrid is not display on browser. Please help.

My views/flexigrid is

<!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Strict//EN” “http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd”>
<html >
<head>
<title>Flexigrid Implemented in CodeIgniter</title>
<link href=“http://localhost/ci/flexgridci/public/css/style.css” rel=“stylesheet” type=“text/css” />
<link href=“http://localhost/ci/flexgridci/public/css/flexigrid.css” rel=“stylesheet” type=“text/css” />
[removed][removed]
[removed][removed]
</head>
<body>
<hr>
<?=$js_grid;?>
<table id=“flex1” ></table>
<hr>
version <?=$version?><hr>
</body>
</html>

The return value of $js_grid is as follows:

[removed]$(document).ready(function(){$(”#flex1”).flexigrid({url: ‘http://localhost/ci/flexigridci/ajax’,dataType: ‘json’,sortname: ‘id’,sortorder: ‘asc’,usepager: true,useRp: true,width: ‘auto’,height: 400,rp: 15,rpOptions: [10,15,20,25,40],pagestat: ‘Displaying: {from} to {to} of {total} items.’,blockOpacity: 0.5,title: ‘Hello’,showTableToggleBtn: true,colModel : [{display: ‘ID’, name : ‘id’, sortable: true, width : 40, align: ‘center’},{display: ‘ISO’, name : ‘iso’, sortable: true, width : 40, align: ‘center’},{display: ‘Name’, name : ‘name’, sortable: true, width : 180, align: ‘left’},{display: ‘Printable Name’, name : ‘printable_name’, sortable: true, width : 120, align: ‘left’},{display: ‘ISO3’, name : ‘iso3’, sortable: true, width : 130, align: ‘left’},{display: ‘Number Code’, name : ‘numcode’, sortable: true, width : 80, align: ‘right’},{display: ‘Actions’,  width : 80, align: ‘right’}],searchitems : [{display: ‘ID’, name : ‘id’, isdefault: true},{display: ‘Name’, name : ‘name’},{display: ‘Number Code’, name : ‘numcode’}],buttons : [{name: ‘Delete’, bclass : ‘delete’, onpress : test},{separator: true},{name: ‘Select All’, bclass : ‘add’, onpress : test},{name: ‘DeSelect All’, bclass : ‘delete’, onpress : test},{separator: true}]}); })[removed]


Thank you very much for response.
new student

 
Posted: 07 April 2009 05:27 PM   [ # 1 ]   [ Rating: 0 ]
Avatar
Joined: 2008-11-16
116 posts

It’s probably a javascript error. In firefox you can open the javascript console and look at what the errors are.

 Signature 

Inside of every large program is a small program struggling to get out.

 
Posted: 08 April 2009 03:39 AM   [ # 2 ]   [ Rating: 0 ]
Joined: 2008-01-13
19 posts

Type the URL of the JSON datafeed (http://localhost/ci/flexigridci/ajax) and see if there are any errors.

also

I had this problem when I was displaying a table with large text fields. I did a trim() around the text and it worked fine.