EllisLab text mark
Advanced Search
     
Bad Gateway or 404page
Posted: 25 January 2009 11:24 AM
Joined: 2009-01-14
16 posts

Hi there,

Can somebody please help me. When I go to my website (eg. http://mysite.com/CI/) it is ok but when I click on my link on the index it gives me a 502 Bad Gateway.

I put a .htaccess file just like on the wiki and when I remove the index.php on the config I’m getting a 404 error Not Found.

I’m using plesk and the version of php is 5.

I changed the uri_protocol to request_uri.

Please help

Thanks and I will appreciate any response

 
Posted: 25 January 2009 04:16 PM   [ # 1 ]   [ Rating: 0 ]
Avatar
Joined: 2007-06-11
2987 posts

This is something you will have to talk to your hosting/server admin about as a 502 error will not be anything to do with CodeIgniter.

 Signature 

————————
Blog | Twitter | GitHub | BitBucket
————————-
PyroCMS - open source modular CMS built with CodeIgniter
PancakeApp - Simple, hosted invoicing/w project management

 
Posted: 11 September 2010 12:22 PM   [ # 2 ]   [ Rating: 0 ]
Joined: 2008-11-06
315 posts
Phil Sturgeon - 25 January 2009 09:16 PM

This is something you will have to talk to your hosting/server admin about as a 502 error will not be anything to do with CodeIgniter.

Today I had a problem, with 502 error: ‘502 Bad Gateway’ when I was using PyroCMS ( v.9.9.7, latest stable). (it was some russian hosting server (never had such problems before on my servers))

I started going step by step. Later I understood, that smth is wrong with Encrypt library (maybe some things not supported or smth ilke that) and I came to solution like this:

Downloaded the Encrypt.php from CI 2.0 branch

and also had turned on database sessions like this:
$config[‘sess_use_database’]  = TRUE;

I I switch back to 1.7.2 Encrypt library or disable the sessions in database I get the error again.

Wanted to post here so anyone else having similar problems on BUGGY servers would save some of their time smile

 
Posted: 02 October 2010 03:42 PM   [ # 3 ]   [ Rating: 0 ]
Joined: 2010-10-02
1 posts

Today I had this same error with CI 1.7.2. I solved it inspired in hugle’s solution by changing this config setting in config.php:

$config[‘sess_encrypt_cookie’] = FALSE;

This seems to not encrypt the cookies and it worked OK. (Buggy Encrypt library maybe?)...