ExpressionEngine 2.8.1 Released

ExpressionEngine 2.8.1 has been released, and is a minor update to fix one JavaScript bug that was fixed the day after 2.8.0’s release. Even though installations without add-ons are likely unaffected, we are considering this a required update for all 2.8.0 users because of the impact it has on so many popular add-ons.

If you’ve already updated to 2.8.0, you don’t have to go through the full update process, you simply need to replace one file (download):

/themes/javascript/compressed/cp/global_start.js 

Optionally, to ensure that your control panel accurately reflects the version and build you are running, you can replace

/system/expressionengine/libraries/Core.php 

And in your config file, update $config['app_version'] to '281'.

Those last two changes are not required to benefit from the fix, and will not affect your ability to update properly to later releases. Since it impacts so many people, we thought an update that included just this fix with instructions on the simple patch to 2.8.0 was a good idea while we are working on a more substantial update.

As always, you can download the update from your Manage Purchases page.

.(JavaScript must be enabled to view this email address) or share your feedback on this entry with @ellislab on Twitter.